[MPlayer-dev-eng] [PATCH] fixes for gcc4
Michael Niedermayer
michaelni at gmx.at
Sat Feb 26 22:56:50 CET 2005
Hi
On Friday 25 February 2005 20:43, Gianluigi Tiesi wrote:
> Updated patches to be compatible with gcc-2.95
> + int ptr;
very missleading name (an integer with name ptr)
> + ptr = ((int) src) + filterSize;
u do not know if a pointer will fit in an int, if it doesnt this will fail
> - :: "r" (src), "m" (dst), "m" (dstWidth), "m" (xInc>>16),
"m" (xInc&0xFFFF)
> + :: "r" (src), "m" (dst), "m" (dstWidth), "m" (x1), "m" (x2)
this is significantly less readable, theres no hope that anyone could guess
from the names x1 and x2 what they are
furthermore theres the fundamental question why exactly every project which
uses asm should rewrite their code for gcc 4, this is not about correct or
incorrect code, its practically just a syntax change
the changes gcc 4 needs makes the code much harder to read, harder to optimize
for the compiler and much longer
is there some bugreport on gccs bugtracker about this? its breaking code which
was valid in the past
--
Michael
"nothing is evil in the beginning. Even Sauron was not so." -- Elrond
More information about the MPlayer-dev-eng
mailing list